(PHP 5 >= 5.5.0, PHP 7, PHP 8)
DateTimeInterface a été créé pour que les déclarations de type de paramètre, retour, ou propriété puissent accepter soit DateTime soit DateTimeImmutable comme valeur. Il n'est pas possible d'implémenter cette interface dans les classes utilisateurs.
Les constantes communes qui permettent de formater les objets DateTimeImmutable ou DateTime via DateTimeImmutable::format() et DateTime::format() sont également définies sur cette interface.
since: '8.5',message: 'this method is obsolete, as serialization hooks are provided by __unserialize() and __serialize()',Atom (exemple: 2005年08月15日T15:52:01+00:00) ; compatible avec ISO-8601, RFC 3339 et XML Schema
HTTP Cookies (exemple: Monday, 15-Aug-2005 15:52:01 UTC)
Semblable à ISO-8601 (exemple: 2005年08月15日T15:52:01+0000)
Note:
Ce format n'est pas compatible avec ISO-8601, mais reste ainsi pour des raisons de compatibilité ascendante. Utiliser DateTimeInterface::ISO8601_EXPANDED, DateTimeInterface::ATOM pour assurer la compatibilité avec ISO-8601. (ref ISO8601:2004 section 4.3.3 clause d)
ISO-8601 Expanded (exemple: +10191-07-26T08:59:52+01:00)
Note:
Ce format permet des plages d'années en dehors de la plage normale de ISO-8601 allant de
0000à9999en incluant toujours un caractère de signe. Il s'assure également que cette partie de fuseau horaire (+01:00) est compatible avec ISO-8601.
RFC 822 (exemple: Mon, 15 Aug 05 15:52:01 +0000)
RFC 850 (exemple: Monday, 15-Aug-05 15:52:01 UTC)
RFC 1036 (exemple: Mon, 15 Aug 05 15:52:01 +0000)
RFC 1123 (exemple: 2005年8月15日 15:52:01 +0000)
RFC 7231 (à partir de PHP 7.0.19 et 7.1.5) (exemple: 2016年4月30日 17:52:13 GMT)
RFC 2822 (exemple: 2005年8月15日 15:52:01 +0000)
Comme DATE_ATOM
RFC 3339 EXTENDED format (exemple : 2005年08月15日T15:52:01.000+00:00)
RSS (exemple: 2005年8月15日 15:52:01 +0000)
World Wide Web Consortium (exemple : 2005年08月15日T15:52:01+00:00)
| Version | Description |
|---|---|
| 8.5.0 |
Les constantes DATE_RFC7231 et
DateTimeInterface::RFC7231 ont été rendues obsolètes.
|
| 8.4.0 | Les constantes de classe sont maintenant typées. |
| 8.2.0 |
La constante DateTimeInterface::ISO8601_EXPANDED
a été ajoutée.
|
| 7.2.0 | Les constantes de classe de DateTime sont maintenant définies sur DateTimeInterface. |
Please note that if you are using DATE_RFC7231 format (used in HTTP/1.1), you'll need to change the DateTime object timezone to GMT *before*, or you'll encounter weird results, as this format DOES NOT convert the date to GMT.
So if you have a DateTime object using UTC+01:00 as its timezone, you will get a difference of 1 hour between your resulting date string and what should be the "correct" date.
Recommended use:
<?php
$date_gmt = clone $date;
$date_gmt->setTimezone(new \DateTimeZone('GMT'));
echo $date_gmt->format(DATE_RFC7231);
?>