On Mon, Aug 24, 2026 at 08:57:12AM -0700, Junio C Hamano wrote: > Junio C Hamano <gitster@xxxxxxxxx> writes: > > > Karthik Nayak <karthik.188@xxxxxxxxx> writes: > > > >> --- > >> Changes in v3: > >> - Move out addition of proc-receive hook doc to 'git-receive-pack.adoc' > >> into a new commit. > >> - Add a new commit to move out the response generation in receive-pack > >> to a new function. > >> - Instead of die-ing on non-zero exit code, we modify each reference to > >> indicate that the hook failed. > >> - Instead of correctly listing out the protocol, link to > >> linkgit:gitprotocol-pack[5], as the protocol also differs between v1 > >> and v2. > >> - Link to v2: https://patch.msgid.link/20260821-758-introduce-hook-v2-1-e90e2f7ac2cf@xxxxxxxxx > > > > This has some interaction with Justin's pluggable writes series. > > Please help sanity check the conflict resolution I did near the tip > > of 'seen' when I push the integration results out later today. > > One more thing. 'report' is far too generic a name for this. There > are other features that plausibly would want to create their own > reports. It is understandable that one can be blinded by the > thought that their invention is more important than everything else, > but please resist such temptation. That's probably on me, as I originally suggested "pre-report" when the design was still in an earlier stage. But I agree with you -- both "pre-report" and "report" are awful names. We have others like "update", which sound way more generic than they really are, but that's not a good reason to repeat that sin. A better name might be "receive-report" or something like that. Patrick