Re: PATCH] cpuidle: A new variant of the menu governor to boost IOperformance
From: Andrew Morton
Date: Mon Sep 14 2009 - 03:45:06 EST
On 2009年9月11日 17:40:19 +0200 Arjan van de Ven <arjan@xxxxxxxxxxxxx> wrote:
>
From: Arjan van de Ven <arjan@xxxxxxxxxxxxxxx>
>
Subject: [PATCH] cpuidle: A new variant of the menu governor
>
>
This patch adds a new idle governor which balances power savings,
>
energy efficiency and performance impact.
>
>
The reason for a reworked governor is that there have been
>
serious performance issues reported with the existing code
>
on Nehalem server systems.
>
>
To show this I'm sure Andrew wants to see benchmark results:
>
(benchmark is "fio", "no cstates" is using "idle=poll")
>
>
no cstates current linux new algorithm
>
1 disk 107 Mb/s 85 Mb/s 105 Mb/s
>
2 disks 215 Mb/s 123 Mb/s 209 Mb/s
>
12 disks 590 Mb/s 320 Mb/s 585 Mb/s
>
>
In various power benchmark measurements, no degredation was found
>
by our measurement&diagnostics team. Obviously a bit more power was
>
used in the "fio" benchmark, due to the much higher performance.
>
>
The integration plan for this is to first add the new governor,
>
but for one kernel generation, leave the old menu governor in place
>
so that it's possible to separate out behavior from this governor
>
versus other things in diagnostics. If no issues are found,
>
I'll remove the old governor in the kernel cycle after that.
>
>
While it would be a novel idea to describe the new algorithm in this
>
commit message, I cheaped out and described it in comments in the
>
code instead.
This fails to compile in linux-next:
drivers/cpuidle/governors/menu-tng.o:(.discard+0x0): multiple definition of `__pcpu_unique_menu_devices'
drivers/cpuidle/governors/menu.o:(.discard+0x0): first defined here
because we have
static DEFINE_PER_CPU(struct menu_device, menu_devices);
in both menu.c and menu-tng.c.
Despite the `static', the percpu changes in
commit 7c756e6e19e71f0327760d8955f7077118ebb2b1
Author: Tejun Heo <tj@xxxxxxxxxx>
AuthorDate: Wed Jun 24 15:13:50 2009 +0900
Commit: Tejun Heo <tj@xxxxxxxxxx>
CommitDate: Wed Jun 24 15:13:50 2009 +0900
percpu: implement optional weak percpu definitions
are emitting global symbol derived from `menu_devices' and they clash.
I'll rename menu_devices to fix that up, but we have a problem...
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
http://vger.kernel.org/majordomo-info.html
Please read the FAQ at
http://www.tux.org/lkml/