Re: [PATCH 1/8] spi: spi-ep93xx: use read,write instead of __raw_*variants
From: Mark Brown
Date: Mon Jul 01 2013 - 06:58:24 EST
On Sat, Jun 29, 2013 at 09:15:09AM +1000, Ryan Mallon wrote:
>
On 29/06/13 04:42, H Hartley Sweeten wrote:
>
> -static inline u8
>
> -ep93xx_spi_read_u8(const struct ep93xx_spi *spi, u16 reg)
>
> -{
>
> - return __raw_readb(spi->regs_base + reg);
>
> -}
>
Is there a particular reason to drop these functions? It's basically just
>
bike-shedding, but they can make the code more readable at very little
>
cost. Even dropping the inline (which is preferred nowdays) the compiler
>
will still inline these, and it would also make this patch much smaller
>
to keep them.
I tend to agree, it's much more normal to have the base + reg in a
function than not.
Attachment:
signature.asc
Description: Digital signature